您现在的位置:
股票非凡网 > 指标公式答疑 > 同花顺MACD面积公式,如何显示小数点后两位数字?

同花顺MACD面积公式,如何显示小数点后两位数字?

网友求助:
公式在同花顺中被四舍五入只显示个位,我想要显示最少小数点后两位数,
我加了 PRECIS2 ,没有作用, *100 的话倒是能显示更多,不过不是原意,
请教各位朋友,   copyright dedecms

公式如下: dedecms.com

DIFF:EMA(CLOSE,S) - EMA(CLOSE,P);
DEA:EMA(DIFF,M);
MACD:2*(DIFF-DEA),COLORSTICK;
MACDHS:=IF(MACD>0 AND MACD>REF(MACD,1),MACD,0);{Www.000001zx.com};
MACDHX:=IF(MACD>0 AND MACD<REF(MACD,1),MACD,0);
MACDLX:=IF(MACD<0 AND MACD<REF(MACD,1),MACD,0);
MACDLS:=IF(MACD<0 AND MACD>REF(MACD,1),MACD,0); 织梦好,好织梦


红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),PRECIS2,COLOR0000FF;
绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(MACD>0)),0),PRECIS2,COLOR006000;;
DRAWTEXT(REF(MACD,1)>0 AND MACD<=0 ,HHV(MACD,4),''+REF(红柱面积,1)),colorred;
DRAWTEXT(REF(MACD,1)<0 AND MACD>=0 ,LLV(MACD,4),''+REF(ABS(绿柱面积),1)),Color00ff00;
DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD<0,LLV(MACD,4),''+ABS(绿柱面积)),Color004A00;
DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD>0,HHV(MACD,4),''+ABS(红柱面积)),colorred; 内容来自dedecms


解答如下:
DRAWTEXT(REF(MACD,1)>0 AND MACD<=0 ,HHV(MACD,4),''+TOSTRING(REF(红柱面积,1),2)),colorred;
DRAWTEXT(REF(MACD,1)<0 AND MACD>=0 ,LLV(MACD,4),''+TOSTRING(REF(ABS(绿柱面积),1),2)),Color00ff00;
DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD<0,LLV(MACD,4),''+TOSTRING(ABS(绿柱面积),2)),Color004A00;{Www.000001zx.com};
DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD>0,HHV(MACD,4),''+TOSTRING(ABS(红柱面积),2)),colorred; copyright dedecms

本站非以盈利为目的,所有信息都是免费的。站内所有广告、网站导航 、及涉及到的所有链接,均与本站无任何关系,请网民自行判断真假,谨防网上股票预测诈骗。