副图中“DMI抄底” 选股公式值等于1时的选股公式_指标公式答疑

股票

副图中“DMI抄底” 选股公式值等于1时的选股公式
发表时间:2013-10-25 21:49来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/dayi/2013102527034.html
  • 网友求助:
    TRA:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),3);
    HD:=HIGH-REF(HIGH,1);
    LD:=REF(LOW,1)-LOW;{Www.000001zx.com};
    DMP:=EMA(IF(HD>0&&HD>LD,HD,0),3);
    DMM:=EMA(IF(LD>0&&LD>HD,LD,0),3);
    PDI:=DMP*100/TRA;
    MDI:=DMM*100/TRA;
    ADX:=EMA(ABS(MDI-PDI)/(MDI+PDI)*100,2);
    OK:PDI<1 AND ADX>90;

     


    解答如下:
    TRA:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),3);
    HD:=HIGH-REF(HIGH,1);
    LD:=REF(LOW,1)-LOW;
    DMP:=EMA(IF(HD>0&&HD>LD,HD,0),3);
    DMM:=EMA(IF(LD>0&&LD>HD,LD,0),3);
    PDI:=DMP*100/TRA;
    MDI:=DMM*100/TRA;{Www.000001zx.com};
    ADX:=EMA(ABS(MDI-PDI)/(MDI+PDI)*100,2);
    OK:=PDI<1 AND ADX>90;
    OK=1;