买卖大底主图:大智慧公式源码_大智慧指标公式

股票

买卖大底主图:大智慧公式源码
发表时间:2016-12-07 22:47来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/dazhihui/2016120732677.html
  • 买:=EMA(C,5);
    A:=(REF(买,1));
    STICKLINE((买>A),A,买,6,0),Colorred;
    STICKLINE((买<=A),A,买,6,0),Colorblue;
    JJ:=(CLOSE+HIGH+LOW)/3;
    W:=EMA(JJ,10);
    E:=REF(A,1);
    STICKLINE((W>E),W,E,6,0),COLORWHITE;
    STICKLINE((E>W),E,W,6,0),COLORYELLOW;
    卖:=EMA(SLOPE(C,21)*20+C,42);
    b:=cross(买,卖);
    drawtext(b,LOW-0.1,'升'),coloryellow,linethick3;
    龙势:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*SMA(SMA((CLOSE-LLV
    (LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1) ;
    大底:=IF(CROSS( 龙势,20),60,0);
    drawtext(大底,LOW-0.5,'强'),colorFF00FF,linethick3;
    多:=ema(c,3);
    空:=ema(c,5);
    均衡:=ema(空,5);
    varf1:=count(cross(多,均衡),2)=1;
    varf2:=count(cross(空,均衡),2)=1;
    zai:=filter(varf1 and varf2,2);
    drawtext(zai,LOW-0.3,'涨'),colorwhite,linethick3;
    h0:=v/capital;
    a1:=IF(h0>0,AMOUNT,c*v*100);
    c1:=sma(ema(a1,3)/ema(v,3)/100,2,1);
    c2:=sma(ema(a1,6)/ema(v,6)/100,2,1);
    c3:=sma(ema(a1,12)/ema(v,12)/100,2,1);
    c4:=sma(ema(a1,24)/ema(v,24)/100,2,1);
    BBI:(C1+C2+C3+C4)/4,colorwhite,linethick1;
    上轨:BBI+3*STD(BBI,13),colorwhite,linethick1;
    下轨:BBI-3*STD(BBI,13),colorwhite,linethick1;
    压力:hhv(h,20),colorFF00FF,linethick2;
    Var1:=REF(CLOSE,2);
    专用:=SMA(MAX(CLOSE-Var1,0),7,1)/SMA(ABS(CLOSE-Var1),7,1)*100;
    Var2:=REF(CLOSE,1);
    Var3:=SMA(MAX(CLOSE-Var2,0),7,1)/SMA(ABS(CLOSE-Var2),7,1)*100;
    极品逃亡:=IF(专用< REF(专用,1) AND 专用>79,专用,0);
    DRAWTEXT(极品逃亡 ,HIGH+0.3,'逃'),colorGREEN,linethick3;
    VAR4:=(2*CLOSE+HIGH+LOW)/4;
    VAR5:=LLV(LOW,5);
    VAR6:=HHV(HIGH,5);
    SK:= EMA((VAR4-VAR5)/(VAR6-VAR5)*100,4);
    SD:= EMA(0.667*REF(SK,1)+0.333*SK,2);
    { 000001在线网_大智慧股票指标公式}
    drawtext(cross(SD,Sk),HIGH+0.6,'短卖'),colorWHITE;
    drawtext(cross(Sk,SD),LOW-0.6,'短买'),colorYELLOW;
    v1:=llv(low,10);
    v2:=hhv(h,25);
    价位线:=ema((c-v1)/(v2-v1)*4,4);
    DRAWTEXT(CROSS(价位线,0.3),low-1.5,'必买'),colorf00ff0;
    DRAWTEXT(CROSS(3.5,价位线),high+1.5,'必卖'),color00ff00;
    MTM:=C-REF(C,1);
    DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
    ZX:=100*EMA(EMA(MTM,12),12)/EMA(EMA(ABS(MTM),12),12);
    CX:=100*EMA(EMA(MTM,26),26)/EMA(EMA(ABS(MTM),26),26);
    DXGD:=LLV(DX,2)=LLV(DX,5) AND CROSS(DX,MA(DX,2));
    短买一:=IF(DXGD AND BETWEEN(DX,0,60) AND ZX>0,1,0);
    清仓:=IF(CROSS(CX,ZX) AND DX<ZX,1,0);
    买一:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
    卖一:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
    DRAWTEXT(filter(短买一 and 短买一<>清仓,4),low-0.03,'△'),COLORFFFFFF;
    DRAWTEXT(清仓 and open>close,high*1.025,'◆'),COLORFF6600;
    DRAWTEXT(filter(买一=1,5),low-0.03,'●'),COLORRED;
    DRAWTEXT(filter(卖一=1,1),high*1.025,'○'),COLOR00FF00;
    RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
    K:=SMA(RSV,3,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
    BDDD:=LLV(J,2)=LLV(J,8);
    J向下拐头:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0);
    DRAWTEXT(j向下拐头 ,high*1.025,'J'),COLORwhite;
    J向上拐头:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,1,0);
    DRAWTEXT(j向上拐头,low-0.03,'J'),COLORff00ff;
    DRAWTEXTREL(0,30,'指示:白▲:短线买 红●:定买 绿○:出逃 紫J:拐头向上 白J:拐头向下 绿◆:清仓'),COLORgreen;
    MA3:=MA(C,3);
    MA5:=MA(C,5);
    ZX:=(MA3+MA5)/2;
    MA20:=MA(C,20);
    MA30:=MA(C,30);
    QSXS:=MA5>=MA30 AND MA30>REF(MA30,1);
    GD:=ZX>=REF(ZX,1) AND REF(ZX,1)<REF(ZX,2);
    YB:=C>REF((O-C)/2+C,2);
    要:=CROSS(C,ZX) AND (GD OR YB) AND QSXS;
    优:=要 AND MA5>REF(MA5,1);
    drawtext(优,LOW-1.1,'优'),coloryellow,linethick2;
    LC:=REF(CLOSE,1);
    RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
    DRAWTEXT(CROSS(84,RSI) , HIGH+1.2,'逃顶 '),COLORCYAN ;
    DRAWTEXT(CROSS(RSI,11) , LOW-1.2,'低吸 '),COLORRED ;
    stickline(isup,low,open,1,1),Color394BEA;
    stickline(isup,open,close,7,1),Color394BEA;
    stickline(isup,close,high,1,1),Color394BEA;
    stickline(isdown,low,close,1,0),colorEF8434;
    stickline(isdown,open,close,7,0),colorEF8434;
    stickline(isdown,open,high,1,0),colorEF8434;