趋势牛股选股:飞狐指标源码公式_飞狐指标公式

股票

趋势牛股选股:飞狐指标源码公式
发表时间:2016-04-13 22:54来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/feihugongshi/2016041330862.html
  • AP0:=SMA(C,3,1),COLORRED;
    AP1:=(55*AP0+34*REF(AP0,1)+21*REF(AP0,2)+13*REF(AP0,3)+8*REF(AP0,4)+5*REF(AP0,5)
    +3*REF(AP0,6)+2*REF(AP0,7)+REF(AP0,8)+REF(AP0,9))/143;
    AP2:=REF(AP1,1);
    XA:=0.5*(AP1+AP2),COLORRED;
    ZD0:=SMA(C,5,1),COLORRED;
    ZD1:=(55*ZD0+34*REF(ZD0,1)+21*REF(ZD0,2)+13*REF(ZD0,3)+8*REF(ZD0,4)+5*REF(ZD0,5)
    +3*REF(ZD0,6)+2*REF(ZD0,7)+REF(ZD0,8)+REF(ZD0,9))/143;
    ZD2:=REF(ZD1,1);
    XA1:=0.5*(ZD1+ZD2),COLORYELLOW;
    H0:=SMA(C,8,1);
    H1:=(55*H0+34*REF(H0,1)+21*REF(H0,2)+13*REF(H0,3)+8*REF(H0,4)+5*REF(H0,5)
    +3*REF(H0,6)+2*REF(H0,7)+REF(H0,8)+REF(H0,9))/143;
    H2:=REF(H1,1);
    XA2:=0.5*(H1+H2),COLORMAGENTA;
    {DRAWBAND(H1,RGB(255,255,0),H2,RGB(0,0,255));
    STICKLINE(H1>H2,H1,H2,10,0),COLORYELLOW;}
    DZ0:=SMA(C,13,1);
    DZ1:=(55*DZ0+34*REF(DZ0,1)+21*REF(DZ0,2)+13*REF(DZ0,3)+8*REF(DZ0,4)+5*REF(DZ0,5)
    +3*REF(DZ0,6)+2*REF(DZ0,7)+REF(DZ0,8)+REF(DZ0,9))/143;
    DZ2:=REF(DZ1,1);
    XA3:=0.5*(DZ1+DZ2),COLORWHITE;
    ZX0:=SMA(C,21,1);
    ZX1:=(55*ZX0+34*REF(ZX0,1)+21*REF(ZX0,2)+13*REF(ZX0,3)+8*REF(ZX0,4)+5*REF(ZX0,5)
    +3*REF(ZX0,6)+2*REF(ZX0,7)+REF(ZX0,8)+REF(ZX0,9))/143;
    ZX2:=REF(ZX1,1);
    XA4:=0.5*(ZX1+ZX2),COLORGREEN;
    I0:=SMA(C,34,1);
    I1:=(55*I0+34*REF(I0,1)+21*REF(I0,2)+13*REF(I0,3)+8*REF(I0,4)+5*REF(I0,5)
    +3*REF(I0,6)+2*REF(I0,7)+REF(I0,8)+REF(I0,9))/143;
    I2:=REF(I1,1);
    XA5:=0.5*(I1+I2),COLORCYAN;
    CX0:=SMA(C,55,1);
    CX1:=(55*CX0+34*REF(CX0,1)+21*REF(CX0,2)+13*REF(CX0,3)+8*REF(CX0,4)+5*REF(CX0,5)
    +3*REF(CX0,6)+2*REF(CX0,7)+REF(CX0,8)+REF(CX0,9))/143;
    CX2:=REF(CX1,1);
    XA6:=0.5*(CX1+CX2),COLORBLUE;
    CC0:=SMA(C,89,1);
    CC1:=(55*CC0+34*REF(CC0,1)+21*REF(CC0,2)+13*REF(CC0,3)+8*REF(CC0,4)+5*REF(CC0,5)
    +3*REF(CC0,6)+2*REF(CC0,7)+REF(CC0,8)+REF(CC0,9))/143;
    CC2:=REF(CC1,1);
    XA7:=0.5*(CC1+CC2),COLORGREEN,LINETHICK2;
    TC0:=SMA(C,144,1);
    TC1:=(55*TC0+34*REF(TC0,1)+21*REF(TC0,2)+13*REF(TC0,3)+8*REF(TC0,4)+5*REF(TC0,5)
    +3*REF(TC0,6)+2*REF(TC0,7)+REF(TC0,8)+REF(TC0,9))/143;
    TC2:=REF(TC1,1);
    XA8:=0.5*(TC1+TC2),COLORMAGENTA,LINETHICK2;
    A0:=IF(XA>REF(XA,1),1,0);
    A1:=IF(XA>=XA1,1,0);
    A2:=IF(XA1>=XA2,1,0);
    A3:=IF(XA2>=XA3,1,0);
    A31:=IF(XA3>=XA4,1,0);
    A32:=IF(XA4>=XA5,1,0);
    A33:=IF(XA5>=XA6,1,0);
    A34:=IF(XA6>=XA7,1,0);
    A35:=IF(XA7>=XA8,1,0);
    A4:=IF(XA3>=REF(XA3,1),1,0);
    A5:=IF(XA4>=REF(XA4,1),1,0);
    A6:=IF(XA5>=REF(XA5,1),1,0);
    A7:=IF(XA2>=REF(XA2,1),1,0);
    A8:=IF(XA6>=REF(XA6,1),1,0);
    A9:=IF(XA7>=REF(A7,1),1,0);
    A10:=IF(XA8>=REF(XA8,1),1,0);
    A11:=IF(XA1>=REF(XA1,1),1,0);
    A12:=IF(AP0>XA,1,0);
    A13:=IF(AP0>REF(AP0,1),1,0);
    B0:=IF(XA<REF(XA,1),-1,0);
    B1:=IF(XA<XA1,-1,0);
    B2:=IF(XA1<XA2,-1,0);
    B3:=IF(XA2<XA3,-1,0);
    B31:=IF(XA3<XA4,-1,0);
    B32:=IF(XA4<XA5,-1,0);
    B33:=IF(XA5<XA6,-1,0);
    B34:=IF(XA6<XA7,-1,0);
    B35:=IF(XA7<XA8,-1,0);
    B4:=IF(XA3<REF(XA3,1),-1,0);
    B5:=IF(XA4<REF(XA4,1),-1,0);
    B6:=IF(XA5<REF(XA5,1),-1,0);
    B7:=IF(XA2<REF(XA2,1),-1,0);
    B8:=IF(XA6<REF(XA6,1),-1,0);
    B9:=IF(XA7<REF(A7,1),-1,0);
    B10:=IF(XA8<REF(XA8,1),-1,0);
    B11:=IF(XA1<REF(XA1,1),-1,0);
    B12:=IF(AP0<=XA,-1,0);
    B13:=IF(AP0<=REF(AP0,1),-1,0);
    日趋势:=((A0+A1+A2+A3+A31+A32+A33+A34+A35+A4+A5+A6+A7+A8+A9+A10+A11+A12+A13+B0+B1+B2+B3+B31+B32+B33+B34+B35+B4+B5+B6+B7+B8+B9+B10+B11+B12+B13)/38)*200,COLORRED,LINETHICK2;
    XG:CROSS(日趋势,90);