实时趋势流主图:飞狐指标源码公式_飞狐指标公式

股票

实时趋势流主图:飞狐指标源码公式
发表时间:2016-04-13 22:54来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/feihugongshi/2016041330865.html
  • X:=SYSPARAM(3)-SYSPARAM(2);
    DRAWTEXTEX(C>0,1,500,5,'['+STKLABEL+']'+ STKNAME+'【可视:'+NUMTOSTR(X,0)+'天】'),Color0077FF,LINETHICK7;
    现价: if (DYNAINFO(4)=0,C,DYNAINFO(7)),color0077FF,POINTDOT;
    KC:=(2*C+H+L+O)/5;
    CB:=SMA(KC,5,1);
    Xl:=slope(CB,3)>0;
    {实时趋势流向}
    动向流:CB,colorFF8DAD;
    ma(动向流,30), colorFF1111,LINETHICK4;
    ma(动向流,29) ,colorFF2222,LINETHICK3;
    ma(动向流,28) ,colorFF3333,LINETHICK2;;
    ma(动向流,27) ,colorFF4444;
    ma(动向流,26) ,colorFF5555;
    ma(动向流,25) ,colorFF6666;
    ma(动向流,24) ,colorFF7777;
    ma(动向流,23) ,colorFF8888;
    ma(动向流,22) ,colorFF9999;
    ma(动向流,21) ,colorFFaaaa;
    ma(动向流,20), colorFFbbbb,LINETHICK3;
    ma(动向流,19) ,colorFFcccc;
    ma(动向流,18), colorFFdddd;
    ma(动向流,17), colorFFeeee;
    ma(动向流,16) ,colorffffFF;
    ma(动向流,15) ,colorEEEEFF;
    ma(动向流,14) ,colorddddFF;
    ma(动向流,13), colorccccFF;
    ma(动向流,12) ,colorbbbbFF;
    ma(动向流,11) ,coloraaaaFF;
    ma(动向流,10) ,color9999FF,LINETHICK3;
    ma(动向流,9) ,color8888FF;
    ma(动向流,8), color7777FF;
    ma(动向流,7) ,color6666FF;
    ma(动向流,6) ,color5555FF;
    ma(动向流,5) ,color4444FF;
    ma(动向流,4) ,color3333FF;
    ma(动向流,3) ,color2222FF;
    ma(动向流,2) ,color1111FF,LINETHICK2;
    close, colorblue,linethick0;
    var1:=(SMA(HIGH,20,2) * 1.05);
    STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFF5B00;
    STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorFF6C00;
    STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorFF7B00;
    STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorFF9C00;
    STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorFFBE00;
    STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorFFCC00;
    STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00;
    STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,9,0),color070084;
    STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),color0000A3;
    STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color0000B7;
    STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color0000CD;
    STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color0000E9;
    STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color0754E9;
    STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color076EF3;
    STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color077BF3;
    STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),color0726CA;
    STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),color0726CA;
    STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),colorDE9100;
    STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),colorDE9100;
    STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,9,0),color0090FF;
    STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,8,0),color009FFF;
    STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,4,0),color00B5FF;
    STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,2,0),color00E4FF;
    STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),OPEN,LOW,0.7,0),color00FFFF;
    STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,HIGH,0.7,0),color00FFFF;
    STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),OPEN,LOW,0.7,0),colorFF76FF;
    STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,HIGH,0.7,0),colorFF76FF;
    STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,9,0),colorFF00FF;
    STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,6,0),colorFF62FF;
    STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,4,0),colorFF76FF;
    STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,2,0),colorFFA8FF;
    STICKLINE(l>ref(h,1),l,ref(h,1),50,1),COLORRED;
    STICKLINE(h<ref(l,1),h,ref(l,1),50,1),colorgreen;
    PARTLINE(Xl-1,CB),COLORGREEN,LINETHICK3;
    PARTLINE(Xl,CB),COLORRED,LINETHICK3;