通道精灵主图:飞狐指标源码公式_飞狐指标公式

股票

通道精灵主图:飞狐指标源码公式
发表时间:2016-06-03 22:19来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/feihugongshi/2016060331992.html
  • AA:=FFT((C+O+L+H)/4,25);
    PARTLINE(AA<REF(AA,1),AA),COLORCYAN;
    PARTLINE(AA>REF(AA,1),AA),COLORRED;
    趋势线:=AA;
    TD上轨:=FFT(aa,30)*1.1;
    TD下轨:=FFT(aa,30)*0.9;
    PARTLINE(TD上轨 >REF(TD上轨,1),TD上轨),COLORWHITE;
    PARTLINE(TD上轨<=REF(TD上轨,1),TD上轨),COLOR999999;
    PARTLINE(TD下轨 >REF(TD下轨,1),TD下轨),COLORFFFF00;
    PARTLINE(TD下轨<=REF(TD下轨,1),TD下轨),COLOR00AAFF;
    底位关注:CROSS(TD下轨,L),LINETHICK;
    DRAWICON(底位关注,TD下轨*0.98,12);
    高位警惕:CROSS(H,TD上轨),LINETHICK;
    DRAWICON(高位警惕,TD上轨*1.04,10);
    ☆:=TD下轨>REF(TD下轨,1) AND REF(TD下轨,1)<REF(TD下轨,2);
    DRAWICON(☆,TD下轨*0.95,8);
    ★:=TD下轨<REF(TD下轨,1) AND REF(TD下轨,1)>REF(TD下轨,2);
    DRAWICON(★,TD上轨*1.02,9);
    {符号熟记时可关闭}
    DRAWTEXT(底位关注,TD下轨*0.94,'底\n位\n关\n注'),SHIFT0,COLORYELLOW;
    DRAWTEXT(高位警惕,TD上轨*1.16,'高\n位\n警\n惕'),SHIFT0,COLORCYAN;
    DRAWTEXT(☆,TD下轨*0.93,'上\n拐\n参\n考'),SHIFT0,COLORRED;
    DRAWTEXT(★,TD上轨*1.02,'下拐\n参考'),SHIFT1,COLORGREEN;
    {均线通道}
    下轨:MA(L,4),COLORYELLOW;
    上轨:MA(H,4),COLORYELLOW;
    中轨:(下轨+上轨)/2,PRECISION2,LINEDOT,COLORGREEN;
    TYP:=(HIGH+LOW+CLOSE)/3;
    cci' target='_blank'>CCI:=(TYP-MA(TYP,5))/(0.015*AVEDEV(TYP,5));
    DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIF,9);
    macd' target='_blank'>MACD:=(DIF-DEA)*2,COLORSTICK;
    主力潜伏:=COUNT(macd' target='_blank'>MACD<0,10)=10,COLORRED, ;
    STICKLINE(主力潜伏,0,macd' target='_blank'>MACD*2 ,1 ,0),COLORRED;
    RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
    K:=SMA(RSV,3,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    J1:=REVERSE(J);
    AA:=REF(MA(C,1),10)>REF(MA(C,60),10);
    买点:=CROSS(J,J1) AND AA;
    VAR01:=EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5);
    VAR02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
    VAR03:=CROSS(VAR02,VAR01);
    VAR04:=REF(VAR02,2)<REF(VAR02,1) AND VAR02<REF(VAR02,1);
    VAR05:=COUNT(VAR03,7)>0 AND VAR04;
    VAR06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VAR07:=SMA(ABS(LOW-VAR06),13,1)/SMA(MAX(LOW-VAR06,0),10,1);
    VAR08:=EMA(VAR07,10);
    VAR09:=EMA(C,5);
    VAR10:=LLV(LOW,33);
    VAR11:=EMA(IF(LOW<=VAR10,VAR09,0),3)*40;
    VAR12:=IF(VAR11>100,VAR11*0.312,VAR11);
    底线:=VAR02,COLORGREEN;
    趋势:=VAR01,COLORCYAN;
    //STICKLINE(VAR05 AND COUNT(VAR05,5)=1,0,VAR12,4,0),COLORRED;
    //sss:=(买点 or VAR05 AND COUNT(VAR05,5)=1) ;
    Var7Bb:=ref(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,1);/////
    VAR4J:=Var7Bb=1;
    sss:=VAR4J;
    sos:=filter(exist(sss,2) and exist(主力潜伏,2),10);
    VARF8:=TROUGHBARS(3,15,1)<10;
    VAR4J:=VARF8=1;
    股必涨:=VAR4J ;//AND COUNT(VAR4J,60)=1
    mm:sos and VAR4J ;
    STICKLINE(mm,0,0.3 ,6,0),COLOR0000FF;
    STICKLINE(mm,0.3 , 0.6 ,8,0),COLORWHITE;
    STICKLINE(mm,0.6 ,0.8 ,10,0),COLORYELLOW;
    DRAWTEXT(mm,0.4 ,'买'),COLORFF00FF;