手把手教你如何制作属于自己的电子股评的两种方法_股票公式教程

股票

手把手教你如何制作属于自己的电子股评的两种方法
发表时间:2013-11-17 17:37来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/jiaocheng/2013111727288.html
  • 1、点击技术分析——在“股票动态行情”点击右键——激活“电子股评”;
    2、在任意一主图或副图指标添加以下一段源码(内容自己修改,下面做例子):

    N2:=1.N1:8;N3:=10;N:=9;M1:=3;M2:=3;
    MA5:=MA(C,5);
    MA10:=MA(C,10);
    MA20:=MA(C,20);
    MA40:=MA(C,40);
    MA60:=MA(C,60);
    MA125:=MA(C,125);
    MA250:=MA(C,250);
    BIAS:=(C-MA20)/MA20*100;
    SHOPEN:=OPEN;
    SHHIGH:=HIGH;
    SHLOW:=LOW;
    SHCLOSE:=CLOSE;
    SHAMOUNT:=AMOUNT;
    SHvol' target='_blank'>VOL:=vol' target='_blank'>VOL;
    J12:=(HIGH - ((HIGH - LOW) / 3));
    J23:=(LOW + ((HIGH - LOW) / 3));
    t1:=(((IF((CLOSE = OPEN),1,0) + IF((CLOSE >= J12),1,0)) + IF((CLOSE <= J23),1,0)) > 1);
    t2:=((((CLOSE > J23) AND (CLOSE < J12)) AND (OPEN > J23)) AND (OPEN < J12));
    t3:=((CLOSE >= J12) AND (OPEN <= J23));
    t4:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE > J12));
    t5:=(((OPEN <= J23) AND (CLOSE <= J12)) AND (CLOSE >= J23));
    t6:=((CLOSE <= J23) AND (OPEN >= J12));
    t7:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE < J23));
    t8:=(((OPEN >= J12) AND (CLOSE <= J12)) AND (CLOSE >= J23));
    t9:=(((SHAMOUNT / SHvol' target='_blank'>VOL) / 100) > REF(HIGH,1));
    t10:=(((SHAMOUNT / SHvol' target='_blank'>VOL) / 100) < REF(LOW,1));
    if DISPSTATUS=2 then begin;
    {Www.000001zx.com整理};var1000:='☆';
    if t1>0 then var1000:=var1000+'☆极端行情,在未来的几日内有85%的机会变更方向。';
    if t2>0 then var1000:=var1000+'☆中性行情,多空双方都未能取得当日行情主动性的控制权';
    if t3>0 then var1000:=var1000+'☆爬升行情,整个交易期间都有买方主导。';
    if t4>0 then var1000:=var1000+'☆爬升行情,信息较少,但收盘期间是买方主导,其他未知。';
    if t5>0 then var1000:=var1000+'☆爬升行情,买方把收盘价拉升到开盘价之上,卖方却也主导一段行情,但不知道是谁主导最后的行情。';
    if t6>0 then var1000:=var1000+'☆漂流行情,整个交易期间都有卖方主导。';
    if t7>0 then var1000:=var1000+'☆漂流行情,信息最少,但收盘期间是卖方主导,其他未知。';
    if t8>0 then var1000:=var1000+'☆漂流行情,卖方把收盘价压至到开盘价之下,买方却也主导一段行情,但不知道是谁主导最后的行情。';
    if t9>0 then var1000:=var1000+'☆上涨趋势。';
    if t10>0 then var1000:=var1000+'☆下跌趋势。';
    if MA20>=MA60 AND CROSS(MA40,MA60) then var1000:=var1000+'☆形成季托,待股价回落到20天均线或40天均线时介入,20天均价为:'+MA20+' 。';
    if BIAS>9.5 AND (C-REF(C,1))/REF(C,1)*100<9.8 then var1000:=var1000+'☆短线涨幅过大,有整理要求。';
    if MA20>=MA60 AND H>=MA20 AND L<=MIN(MA40,MA60) AND C>O AND C>REF(C,1) then var1000:=var1000+'☆芙蓉出水,趋势向好。';
    if BIAS<-18 AND (C-REF(C,1))/REF(C,1)*100>-9.8 then var1000:=var1000+'☆股价严重超跌,有爆发要求。';
    if BIAS<-7 AND ALL(CLOSE<OPEN,5) then var1000:=var1000+'☆连收五阴,超跌有反弹要求。';
    if ABS(HIGH-REF(HIGH,1))/HIGH<0.001 then var1000:=var1000+'☆平顶,-该高点有一定阻力。';
    if ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.00 then var1000:=var1000+'☆平底,该低点有一定支撑。';
    if CLOSE=OPEN AND HIGH<>close and low<>close and HIGH/LOW > 1.03 then var1000:=var1000+'☆ 长十字,多空激争 前途未明。';
    if OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018 then var1000:=var1000+'☆ 大阴烛,今日空方有绝对优势。';
    if REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98 then var1000:=var1000+'☆双飞乌鸦,多头力竭,行情走软。';
    if (MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667 then var1000:=var1000+'☆长下影,下档支撑强或空方试探进攻。';
    if (HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667 then var1000:=var1000+'☆长上影,上档阻力大或多方试探进攻。';
    if CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH then var1000:=var1000+'☆垂死十字,在顶部时重要 表强力多头开始疲软。';
    if HIGH=CLOSE AND HIGH<>LOW then var1000:=var1000+'☆光头阳线,今日尾盘多方气盛,行情可能延续到明天。';
    if (HIGH<REF(LOW,1) OR LOW>REF(HIGH,1)) then var1000:=var1000+'☆跳空缺口,当日未补,有与跳空同向进行,上涨欲望强烈,三日内为回补观察期。';
    if LOW=CLOSE AND HIGH<>LOW then var1000:=var1000+'☆赤脚阴线,尾盘空方胜。 注意股价下跌延续至次日。';
    if CLOSE=OPEN AND HIGH<>close and low<>close and high <>close then var1000:=var1000+'☆十字星,警告信号。原趋势停顿或反转,依上下影线长度判后市。';
    if CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018 then var1000:=var1000+'☆大阳烛,上升行情中意味行情剧烈向上攀升;下跌行情中意味行情剧烈向上反弹。';
    IF REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1)AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2) THEN
    var1000:=var1000+'☆早晨十字,如同晨星。 从看空平衡到看涨转强;左右跳空曰弃婴 。';
    IF REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4) THEN var1000:=var1000+'☆上升三部曲,空方卖压被吸纳。 趋势易顺势走涨。';
    IF (ref(high,2) -ref(o,2))/ref(high,2)<=0.0003 AND (c-low)/o<=0.0003 AND ref(c,2)<ref(o,2) AND ref(c,2)>ref(o,1) AND ref(c,1)>o AND ref(c,1)<ref(o,1) AND ref(high,1)-ref(o,1)>0 AND ref(low,1)-ref(c,1)<0 AND high-o>0 AND ref(c,2)-ref(low,2)>0 THEN var1000:=var1000+'☆三胎乌鸦,多头走势被扭转。黑K价愈深量愈大,跳空愈大,反转信号愈强。';
    IF ((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)) THEN
    var1000:=var1000+'☆友好反攻,阴(阳)线结合,极线多方跳低(高)后反弹有企稳迹象 。';
    IF close<>open and MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5) THEN
    var1000:=var1000+'☆射击之星,如伴大量上遇阻力,有短期见顶可能,股价转疲。';
    IF REF(CLOSE,1)-REF(OPEN,1)<0 AND CLOSE-OPEN>0 AND OPEN-REF(CLOSE,1)<0 AND CLOSE<REF(OPEN,1) AND CLOSE>REF(CLOSE,1) AND CLOSE>(REF(CLOSE,1)+REF(OPEN,1))/2 THEN
    var1000:=var1000+'☆贯穿线,多头力道的反扑或是空单回补力道。长黑之后开低收在前天1/2之上,为多头反转信号。';
    IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
    var1000:=var1000+'☆身怀六甲,阴(阳)怀阳(阴),怪异的走势,显示该股行情可能转向。 若量由大转缩,下跌趋势更明确。';
    IF (ref(c,1)-ref(o,1)<0 AND c-o>0 AND c>ref(o,1) AND o<ref(c,1)) THEN
    var1000:=var1000+'☆多头阳线吞噬,红包黑。反转趋势需量能配合量。 ';
    IF ((ref(c,2)-ref(o,2)>0 AND (ABS(ref(c,2)-ref(o,2)))/(ABS(ref(c,3)-ref(o,3)))>2.4 AND ABS(c-o)>3 AND ABS(ref(c,2)-ref(o,2))>(ABS(ref(c,1)-ref(o,1))) AND ref(c,1)-ref(o,1)>0 AND c-o<0 AND ref(o,1) >ref(c,2) AND o<ref(o,1) AND c<ref(c,2) AND c>ref(o,2)) OR (ref(c,2)-ref(o,2)>0 AND (ABS(ref(c,2)-ref(o,2)))/(ABS(ref(c,3)-ref(o,3)))>2.4 AND ABS(c-o)>3 AND (ABS(ref(c,2)-ref(o,2)))>(ABS(ref(c,1)-ref(o,1))) AND ref(c,1)-ref(o,1)<0 AND c-o<0 AND ref(c,1) >ref(c,2) AND c<ref(c,2) AND c>ref(o,2) AND o<ref(c,1))) THEN
    var1000:=var1000+'☆夜星,从看多平衡到看空转弱,转空。 ';
    IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
    var1000:=var1000+'☆十字胎,似身怀六甲,转向可能性更大,量缩观望为宜 。';
    IF ref(c,1)<ref(o,1) AND c-o>0 AND c>ref(H,1) AND o<ref(L,1) and ref(O,1)>ref(max(O,C),2) and ref(C,1)>ref(min(O,C),2) and ref(max(O,C),2)>ref(max(O,C),3) THEN
    var1000:=var1000+'☆ 双人殉情 ,在上升趋势中最后之空头吞噬,也就是所谓的不见长红不回头。 ';
    IF (ref(c,1)-ref(o,1)>0 AND c-o<0 AND c<ref(o,1) AND o>ref(c,1)) THEN
    var1000:=var1000+'☆阴线吞噬,黑包红,向空反转。 ';
    IF REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1) THEN var1000:=var1000+'☆曙光,与乌云盖顶相反,行情将演化为V型反转或止跌横盘趋势 。';
    IF (ref(c,1)-ref(o,1)<0 AND c-o>0 AND c<ref(o,1) AND o>ref(c,1)) THEN
    var1000:=var1000+'☆多头孕育线,阴育阳。多头反转可能。'; {Www.000001zx.com整理};
    IF (ref(c,1)-ref(o,1)>0 AND (ABS(ref(c,1)-ref(o,1)))/(ABS(ref(c,2)-ref(o,2)))>2.4 AND c-o<0 AND c>ref(o,1) AND ref(c,1)-o>2) THEN
    var1000:=var1000+'☆空头孕育线,阳育阴。看空 。';
    IF (ref(c,1)-ref(o,1)<0 AND c-o<0 AND c>ref(c,1) AND o<ref(o,1) AND o-c <6) THEN
    var1000:=var1000+'☆空头孕育线,阴育阴。看空。';
    IF REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1) THEN
    var1000:=var1000+'☆三只乌鸦,强烈转空趋势。三黑K价越深量越大越易下跌。';
    IF REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4) THEN
    var1000:=var1000+'☆下跌三部曲,多方弱势不堪一击,趋势易顺势走跌。';
    IF REF(CLOSE,4)/REF(OPEN,4)>1.02 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(close,4)<=REF(close,3) AND REF(high,2)<REF(high,3) AND REF(LOW,2)>=REF(open,4) AND REF(high,1)<REF(close,4) AND REF(low,1)>REF(open,4) AND CLOSE/OPEN>1.01 AND open>=REF(open,1) AND CLOSE>=REF(HIGH,3) THEN
    var1000:=var1000+'☆连续型态之执垫,比上升三法更具多头意义。';{Www.000001zx.com整理};
    IF ref(O,1)/ref(C,1) > 1.05 AND ref(H,1)/ref(L,1) < ref(O,1)/ref(C,1)+0.018 and C>O and O<ref(L,1) and C=ref(L,1) THEN
    var1000:=var1000+'☆颈上线,下降趋势。若第二天大量,维持原趋势可能星大增。';
    IF (ref(c,1)-ref(o,1)>0 AND (ABS(ref(c,1)-ref(o,1)))/(ABS(ref(c,2)-ref(o,2)))>2.5 AND c-o<0 AND c>ref(o,1) AND c<(REF(CLOSE,1)+REF(OPEN,1))/2 AND o>ref(c,1)) THEN
    var1000:=var1000+'☆乌云罩顶,上涨遇重大阻力。空头聚力。';
    IF (ref(c,1)-ref(o,1)>0 AND c-o<0 AND c<ref(o,1) AND o>ref(c,1)) THEN
    var1000:=var1000+'☆最后吞噬,在下降趋势中为一黑一红组合;多头吞噬,在上升趋势中为一红一黑组合,空头吞噬。';
    IF ref(open,1)<>ref(close,1) and REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2) THEN
    var1000:=var1000+'☆晨星,多方势盛 变盘信号';
    IF MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5) THEN var1000:=var1000+'☆ 倒转槌头 -高位抛压 低位多空争执';{Www.000001zx.com整理};
    IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5) THEN var1000:=var1000+'☆槌头,下影线有多头意义。在下降趋势之后看涨。注意反弹卖压 。';
    IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE > MA(CLOSE,5) THEN var1000:=var1000+'☆吊颈线,高档看跌。';
    IF ((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1)) OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))) THEN
    var1000:=var1000+'☆ 穿头破脚 -若第一根K为阴(阳) 表强劲上涨(下跌)力量。';
    IF ref(open,1)<>ref(close,1) and REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2) THEN
    var1000:=var1000+'☆黄昏之星,空方势盛。反转信号,跳空成弃婴。';
    IF REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100 THEN var1000:=var1000+'☆二阳夹一阴,必须从后续的走势来研判。';
    IF OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0 THEN
    var1000:=var1000+'☆ 分离 -两日开盘相同 一阴一阳 变盘前彻底整理。';
    IF ((O>C and open>MA(C,5) and Open>MA(C,10) and O>MA(C,20) and Close<MA(C,5) and Close<MA(C,10) and Close<MA(C,20)) OR (O<C and open<MA(C,5) and Open<MA(C,10) and O<MA(C,20) and Close>MA(C,5) and Close>MA(C,10) and Close>MA(C,20))) THEN var1000:=var1000+'☆断头铡刀(出水芙蓉) -一根大阴(阳)线切断了三根均线 如果改变了其后均线的排列为空头(多头)排列 后势看空(多) 。';
    end;
    TIPTEXT(DISPSTATUS=2,0,var1000);

    3、刷新下行情,在股评一栏就可以看到实时股评。