MACB叠加KDJ指标:飞狐公式_经典股票指标

股票

MACB叠加KDJ指标:飞狐公式
发表时间:2013-11-04 16:43来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/jingdian/2013110427159.html
  • DIFF : EMA(C,12) - EMA(C,26),PRECISION2,
    LINETHICK2,COLORGREEN;
    {Www.000001zx.com};DEA : EMA(DIFF,9),
    PRECISION2,LINETHICK2,ColorFFA800;
    MACD : 2*(DIFF-DEA),PRECISION2,LINETHICK,COLORGRAY;
    {kdj}
    {Www.000001zx.com};RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
    K:SMA(RSV,3,1),PRECISION2,LINETHICK,COLORWHITE;D:SMA(K,3,1),PRECISION2,LINETHICK,COLORYELLOW;
    J:3*K-2*D,PRECISION2,LINETHICK,ColorFF80FF;
    {叠加}
    n1:=sysparam(3); n2:=sysparam(2); n3:=(n1-n2)+1; hh:=hhv(DIFF,n3); ll:=llv(MACD,n3);
    zhh:=hh[n1]; zll:=ll[n1]; Rh:=hhv(J,0); RL:=LLv(J,0); q:=datacount;
    Rb:=(zhh-zll)/(RH[q]-RL[q]); Ry:=(zhh+zll-rb*(RH[q]+RL[q]))/2;
    叠K:=k*rb+ry; 叠D:=d*rb+ry; 叠J:=J*rb+ry;{Www.000001zx.com};
    STICKLINE(MACD<ref(MACD,1) and MACD<0,0,MACD,0,0),ColorFFCF78;
    STICKLINE(MACD<ref(MACD,1) and MACD>0,0,MACD,0,0),COLORYELLOW;
    STICKLINE(MACD>ref(MACD,1) and MACD<0,0,MACD,0,0),COLORMAGENTA;
    STICKLINE(MACD>ref(MACD,1) and MACD>0,0,MACD,0,0),COLORRED;
    PARTLINE(1,叠K),COLORWHITE;
    PARTLINE(1,叠D),COLORYELLOW;
    PARTLINE(1,叠J),ColorFF80FF;