您现在的位置:
股票非凡网 > 通达信指标公式 > 大单动向DDX 涨跌动因DDY 大单分差DDZ 动力线4个指标-通信达顶级

大单动向DDX 涨跌动因DDY 大单分差DDZ 动力线4个指标-通信达顶级

JJ:=(OPEN+HIGH+LOW+CLOSE)/4;
AA:=IF(BETWEEN(C,JJ,H) OR C=O,VOL,0);
BB:=IF(BETWEEN(C,JJ,L),VOL,0);
CC:=IF(AA AND BB,0,VOL/3);
DDX:10*(AA-(BB+CC))/IF(CAPITAL<1,SUM(VOL,13),CAPITAL),LINETHICK0;
STICKLINE(DDX>0,0,DDX,2.5,0 ),COLOR0022FF;
{STICKLINE(DDX>0,0,DDX,2,0 ),COLORBB22CC;}
STICKLINE(DDX<0,0,DDX,2.5,0 ),COLORFFFF00;
DDX1:EMA(DDX,60)*60,COLOR00FFFF;
DDX2:MA(DDX1,5),COLORFF00FF;
DDX3:MA(DDX2,10),COLOR00FF00;
预警:DDX>0 AND CROSS(DDX1,DDX2) AND (CLOSE/REF(CLOSE,1)-1)*100>=3,LINETHICK0;
DRAWTEXT(预警,0,'★'),LINETHICK3,COLOR00FFFF;
{DRAWTEXT(C,1,'大单动向'),COLORFFFFFF;}
大单动向:0.5.POINTDOT,COLORBLUE;
{以上是大单动向 DDX}

{涨跌动因 DDY}
AA:=IF(BETWEEN(C,REF(C,1),H),VOL,0);
BB:=IF(BETWEEN(C,REF(C,1),L),VOL,0);
CC:=IF(AA AND BB,0,VOL/3);
DDY:3*(AA-(BB+CC))/IF(CAPITAL<1,SUM(INDEXV,71),CAPITAL),LINETHICK0;
STICKLINE(DDY>0,0,DDY,2.5,0 ),COLORRED; 本文来自织梦
STICKLINE(DDY<0,0,DDY,2.5,0 ),COLORGREEN;
DDY1:EMA(DDY,60)*60,COLOR00FFFF;
DDY2:MA(DDY1,5),COLORFF00FF;
DDY3:MA(DDY1,10),COLOR00FF00;
预警:DDY>0 AND CROSS(DDY1,DDY3) AND (CLOSE/REF(CLOSE,1)-1)
*100>3,LINETHICK0;
DRAWTEXT(预警,0,'★'),LINETHICK3,COLOR00FFFF;
{DRAWTEXT(C>0,0,'涨跌动因'),COLORFFFFFF;}
涨跌动因:0.5,POINTDOT,COLORBLUE;

{大单分差' DDZ }
INPUT:P1(170),P2(200);}
CC:=IF(CAPITAL<1,INDEXV*0.618,VOL/3);
H1:=VOL/CAPITAL*100;
H2:=INDEXV/SUM(INDEXV,71)*100;
HS:=IF(CAPITAL<1,H2,H1);
JJ:=IF(CAPITAL<1,INDEXA/INDEXV/100,(OPEN+HIGH+LOW+CLOSE)/4);
AA:=IF(BETWEEN(CLOSE,JJ,HIGH) OR CLOSE=OPEN,VOL,0);
BB:=IF(BETWEEN(CLOSE,JJ,LOW) OR CLOSE<OPEN,VOL,0);
DDZ:HS*(BB-(AA+CC))/(CC-(AA-BB))*P2/100,LINETHICK0;
DDZ1:HS*(BB-(AA+CC))/(CC-(AA-BB))*P1/100,LINETHICK0;
{FILLRGN}
DRAWKLINE(DDZ>DDZ1,1,DDZ,DDZ1),COLOR0000FF;
{FILLRGN} dedecms.com
DRAWKLINE(DDZ<DDZ1,3,DDZ,DDZ1),COLOR00FF00;
{DRAWTEXT(CLOSE>0,1,'大单分差'),COLORFFFFFF;};


{动力线指标 原码}
量:=V;
换手:V/CAPITAL*100,LINETHICK0;
VAR1:=VOL/((H-L)*2-ABS(C-O));
买盘:=IF(C>O,VAR1*(H-L),IF(C<O,VAR1*((H-O)+(C-L)),VOL/2));
卖盘:=IF(C>O,0-VAR1*((H-C)+(O-L)),IF(C<O,0-VAR1*(H-L),0-VOL/2));
DLX:(买盘-(-卖盘))/量*换手,COLORAAFF3D,LINETHICK0;
STICKLINE((买盘-(-卖盘))/量*换手,DLX,0,2,0),VOLSTICK;
DLX1:SUM(DLX,6),COLORYELLOW;
DLX2:MA(DLX1,5);
DLX3:MA(DLX1,10);
 
织梦好,好织梦

本站非以盈利为目的,所有信息都是免费的。站内所有广告、网站导航 、及涉及到的所有链接,均与本站无任何关系,请网民自行判断真假,谨防网上股票预测诈骗。