红绿灯+KDJ背离:同花顺软件源码_同花顺指标公式

股票

红绿灯+KDJ背离:同花顺软件源码
发表时间:2016-06-12 21:36来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/tonghuashun/2016061232409.html
  • N:=9;M1:=3;M2:=3;
    RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
    K:SMA(RSV,M1,1),coloryellow,LINETHICK1;
    D:SMA(K,M2,1),colorcyan,LINETHICK1;
    J:3*K-2*D,colormagenta,LINETHICK1;
    高安全区:0,colorred;
    安全区:20,colorcyan;
    风险区:100,colorgreen;
    U1:=BARSLAST(REF(CROSS(K,D),1));
    U2:=REF(C,U1+1)>C AND REF(K,U1+1)<K AND CROSS(K,D)AND d<50;
    底背离:=IF(U2>0,1,0);
    DRAWLINE(U1=0,D,底背离,REF(D,U1),0),colorred,LINETHICK2;
    DRAWLINE(底背离,D,底背离,REF(D,U1),0),colorred,LINETHICK2;
    //{www.000001zx.com 000001在线_同花顺股票指标公式}
    DRAWTEXT(底背离,REF(D,U1)*1.00,' 底背离'),coloryellow;
    rr:=MAX(C,O);
    q1:=HHV(rr,5);
    q2:=d<REF(d,1) AND REF(d,1)>REF(d,2);
    A2:=BARSLAST(REF(q2,1));
    顶背离:= REF(q1,A2+1)<q1 AND k<REF(k,A2+1) AND q2;
    DRAWLINE(A2=0 ,D,顶背离,REF(D,A2),0),colorwhite,LINETHICK2;
    DRAWLINE(顶背离,D,顶背离,REF(D,A2),0),colorwhite,LINETHICK2;
    DRAWTEXT(顶背离,REF(D,A2)*1.02,' 顶背离'),colorgreen;
    Var3:=(2*CLOSE+HIGH+LOW)/4;
    Var4:=LLV(LOW,34);
    VarA:=HHV(HIGH,34);
    VarB:=EMA((Var3-Var4)/(VarA-Var4)*100,13);
    VarC:=EMA(0.667*REF(VarB,1)+0.333*VarB,2);
    oo:=VarB-VarC;
    STICKLINE(oo>0,VarB,VarC,8,0),colorred;
    STICKLINE(oo<0,VarB,VarC,8,0),colorgreen;
    警戒线:80 ;
    启动线:20 ;