小天KDJ:同花顺软件源码_同花顺指标公式

股票

小天KDJ:同花顺软件源码
发表时间:2016-06-12 21:36来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/tonghuashun/2016061232410.html
  • RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
    K:=SMA(RSV,3,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
    K12:=SMA(RSV12,3,1);
    D12:=SMA(K12,3,1);
    J12:=3*K12-2*D12;
    RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
    K24:=SMA(RSV24,3,1);
    D24:=SMA(K24,3,1);
    J24:=3*K24-2*D24;
    U2L:=IF(C>=MA(C,20),80,50);
    L2L:=IF(C>=MA(C,20),50,20);
    RH1:=IF(j< U2L AND REF(j,1)>=U2L,HHV(REF(H,1),BARSLAST(j>=U2L AND REF(j,1)< U2L)-1),REF(HHV(REF(H,1),BARSLAST(j>=U2L AND REF(j,1)< U2L)-1),BARSLAST(j< U2L AND REF(j,1))));
    RH4:=IF(H>RH1,L,REF(L,BARSLAST(H>RH1)));
    RH42:=IF(H>RH1,j,REF(j,BARSLAST(H>RH1)));
    //{www.000001zx.com 000001在线_同花顺股票指标公式}
    RL1:=IF(j>L2L AND REF(j,1)<=L2L,LLV(REF(L,1),BARSLAST(j<=L2L AND REF(j,1)>L2L)-1), REF(LLV(REF(L,1),BARSLAST(j<=L2L AND REF(j,1)>L2L)-1),BARSLAST(j>L2L AND REF(j,1))));
    RL4:=IF(L< RL1,H,REF(H,BARSLAST(L< RL1)));
    RL42:=IF(L< RL1,j,REF(j,BARSLAST(L< RL1)));
    cb:=AMOUNT/V/100;
    cd:=cb>H OR cb< L;
    A:= cb-0.002,STICK,LINETHICK4,colorffaa00;
    支撑位:IF(CROSS(j,j24),L,REF(L,BARSLAST(CROSS(j,j24)))),coloryellow,LINETHICK2;
    压力位:IF(CROSS(j24,j),H,REF(H,BARSLAST(CROSS(j24,j)))),colorred,LINETHICK2;
    RH5:IF(H>RH4 AND j< RH42 AND j< j24,H,REF(H,BARSLAST(H>RH4 AND j< RH42 AND j< j24))),COLORF000FF;
    RL5:IF(L< RL4 AND j>RL42 AND j>j24,L,REF(L,BARSLAST(L< RL4 AND j>RL42 AND j>j24))),colorwhite;
    小天导航:MA(C,3),COLOR00FF00;