神马:同花顺软件源码_同花顺指标公式

股票

神马:同花顺软件源码
发表时间:2016-06-12 21:36来源:股票指标网
  • 本文来源: http://www.gupiaoff.com/tonghuashun/2016061232414.html
  • ZF:=(H-L)/REF(C,1)*100;
    TJ:=ZF/REF(ZF,1)>1.1 AND V/REF(V,1)>1.1 AND C>O;
    A1:=BARSLAST(REF(CROSS("macd' target='_blank'>MACD.DIF","macd' target='_blank'>MACD.DEA"),1));
    B1:=REF(C,A1+1)>C AND REF("macd' target='_blank'>MACD.DIF",A1+1)<"macd' target='_blank'>MACD.DIF" AND CROSS("macd' target='_blank'>MACD.DIF","macd' target='_blank'>MACD.DEA");
    DRAWTEXT(FILTER(B1>0,5),L-0.38,'macd' target='_blank'>MACD底背'),COLORGREEN;
    A2:=BARSLAST(REF(CROSS("kdj' target='_blank'>KDJ.K","kdj' target='_blank'>KDJ.D"),1));
    B2:=REF(C,A2+1)>C AND REF("kdj' target='_blank'>KDJ.K",A2+1)<"kdj' target='_blank'>KDJ.K" AND CROSS("kdj' target='_blank'>KDJ.K","kdj' target='_blank'>KDJ.D");
    DRAWTEXT(FILTER(B2>0,5),L-0.39,'kdj' target='_blank'>KDJ底背'),COLORYELLOW;
    A3:=BARSLAST(REF(CROSS("rsi' target='_blank'>RSI.rsi' target='_blank'>RSI1","rsi' target='_blank'>RSI.rsi' target='_blank'>RSI2"),1));
    B3:=REF(C,A3+1)>C AND REF("rsi' target='_blank'>RSI.rsi' target='_blank'>RSI1",A3+1)<"rsi' target='_blank'>RSI.rsi' target='_blank'>RSI1" AND CROSS("rsi' target='_blank'>RSI.rsi' target='_blank'>RSI1","rsi' target='_blank'>RSI.rsi' target='_blank'>RSI2");
    DRAWTEXT(FILTER(B3>0,5),L,'rsi' target='_blank'>RSI底背'),COLORCYAN;
    C1:=BARSLAST(REF(CROSS("macd' target='_blank'>MACD.DEA","macd' target='_blank'>MACD.DIF"),1));
    D1:=REF(C,C1+1)<C AND REF("macd' target='_blank'>MACD.DIF",C1+1)>"macd' target='_blank'>MACD.DIF" AND CROSS("macd' target='_blank'>MACD.DEA","macd' target='_blank'>MACD.DIF");
    DRAWTEXT(FILTER(D1>0,5),H+0.08,'macd' target='_blank'>MACD顶背'),COLORWHITE;
    C2:=BARSLAST(REF(CROSS("kdj' target='_blank'>KDJ.D","kdj' target='_blank'>KDJ.K"),1));
    D2:=REF(C,C2+1)<C AND REF("kdj' target='_blank'>KDJ.K",C2+1)>"kdj' target='_blank'>KDJ.K" AND CROSS("kdj' target='_blank'>KDJ.D","kdj' target='_blank'>KDJ.K");
    DRAWTEXT(FILTER(D2>0,5),H+0.32,'kdj' target='_blank'>KDJ顶背'),COLORWHITE;
    C3:=BARSLAST(REF(CROSS("rsi' target='_blank'>RSI.rsi' target='_blank'>RSI2","rsi' target='_blank'>RSI.rsi' target='_blank'>RSI1"),1));
    D3:=REF(C,C3+1)<C AND REF("rsi' target='_blank'>RSI.rsi' target='_blank'>RSI1",C3+1)>"rsi' target='_blank'>RSI.rsi' target='_blank'>RSI1" AND CROSS("rsi' target='_blank'>RSI.rsi' target='_blank'>RSI2","rsi' target='_blank'>RSI.rsi' target='_blank'>RSI1");
    DRAWTEXT(FILTER(D3>0,5),H+0.1,'rsi' target='_blank'>RSI顶背'),COLORMAGENTA;
    MA5:EMA(CLOSE,5),COLORYELLOW;
    MA10:EMA(CLOSE,10),COLORFFFFFF;
    MA30:EMA(CLOSE,30),COLORFF0000;
    MA60:EMA(CLOSE,60),COLORRED;
    VAR37:=EMA(EMA(EMA(CLOSE,2),2),2);
    VAR47:=(MA(VAR37,47))*(0.99);
    分水岭:(MA(VAR37,13))*(0.99),LINETHICK2,COLORFF00FF;
    DRAWTEXT((MA(CLOSE,13) > MA(CLOSE,18)) AND CROSS(CLOSE,MA(CLOSE,4)) AND (MA(CLOSE,4) < MA(CLOSE,13)),(LOW)*(0.97),'赢'),COLOR00FF00;
    B36:=MA(CLOSE,3) - MA(CLOSE,6);
    B612:=MA(CLOSE,6) - MA(CLOSE,12);
    J:=((B36)/(CLOSE))*(10);
    J1:=((B612)/(CLOSE))*(10);
    DRAWTEXT((J < (-0.2)) AND (J1 < (-0.2)) AND CROSS(J,J1),(LOW)*(0.95),'猎庄'),COLORRED;
    KS:=((CLOSE - MA(CLOSE,13))/(MA(CLOSE,13)))*((-200));
    RKS:=REF(KS,1);
    FT:=((RKS)/(KS) >= 1.23) AND (RKS >= 8) AND ((CLOSE)/(REF(CLOSE,1)) >= 1.03);
    反弹:STICKLINE(FT,HIGH,LOW,0,1),LINETHICK2,COLOR00FF00;
    STICKLINE(FT,OPEN,CLOSE,8,0),COLORYELLOW;
    VAR10:=MA(CLOSE,80) - (MA(CLOSE,10))/(3);
    VAR11:=REF(CLOSE,1);
    VAR12:=((SMA(MAX(CLOSE - VAR11,0),18,1))/(SMA(ABS(CLOSE - VAR11),18,1)))*(100);
    DRAWICON(CROSS(79,VAR12),(HIGH)*(1.035),2),COLOR008000;
    //{www.000001zx.com 000001在线_同花顺股票指标公式}
    DRAWTEXT(CROSS(79,VAR12),(HIGH)*(1.04),' 抛↓'),COLORFFFFFF;
    VAR1:=LLV(LOW,22);
    VAR2:=HHV(HIGH,22);
    AK1:=EMA(((CLOSE - VAR1)/(VAR2 - VAR1))*(100),5);
    AK:=EMA(((CLOSE - VAR1)/(VAR2 - VAR1))*(50),13);
    DD:=EMA((0.667)*(REF(AK1,1)) + (0.333)*(AK1),2);
    VAR3:=LLV(LOW,55);
    VAR4:=HHV(HIGH,34);
    VAR5:=EMA(((CLOSE - VAR3)/(VAR4 - VAR3))*(100),3);
    VAR6:=(AK + VAR5)/(2);
    VAR7:=EMA((0.667)*(REF(VAR5,1)) + (0.333)*(AK1),2);
    VAR8:=EMA(VAR6,5);
    BB:=EMA((0.667)*(REF(VAR8,1)) + (0.333)*(VAR8),2);
    AB:=CROSS(AK1,AK);
    BB1:=CROSS(AK1,BB) AND (BB < 30);
    CD:=(BB1)*(0.6);
    DRAWTEXT((CD = 0.6),(LOW)*(0.98),'□'),LINETHICK1,COLORFFFFFF;
    DRAWTEXT((AB = 1),(LOW)*(0.98),'■'),LINETHICK1,COLOR66FFCC;
    DRAWTEXT((AB = 1),(LOW)*(0.94),'拐点 '),COLOR33CC99;
    VAR111:=(((CLOSE - MA(CLOSE,6))/(MA(CLOSE,6)))*(200) + ((CLOSE - MA(CLOSE,24))/(MA(CLOSE,24)))*(200) + ((CLOSE - MA(CLOSE,32))/(MA(CLOSE,32)))*(200))/(3);
    DRAWICON((VAR111 > 20) AND FILTER((VAR111 < REF(VAR111,1)),5),(HIGH)*(1.02),2),COLORFF00FF;